ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Z W" <mpc8...@gmail.com>
Subject Re: condition question
Date Wed, 06 Feb 2008 21:37:54 GMT
Charbel
thanks for the response.
I still get the same problem with that small change.


<echo> confused ${confused} </echo>

<condition property="retest6" value="3" else="6">

<equals arg1="${confused}" arg2="5" />

</condition>

<echo> retest ${retest6}</echo>


_recheck:
     [echo]  confused 5
     [echo]
Condition false; setting retest6 to 6
Setting project property: retest6 -> 6
     [echo]  retest 6
Property "retest" has not been set

On Feb 6, 2008 11:12 AM, Charbel BITAR <bitarch@gmail.com> wrote:

> Double check the name of the property in your code :
>
> <condition property="*retest6*" value="3" else="6">
> ...
> <echo> retest *${retest}*</echo>
> --
> Charbel
>
>
>
> On Feb 6, 2008 7:59 PM, Z W <mpc8250@gmail.com> wrote:
>
> > Hi
> >
> > Why is this condition failing/false when "confused" is 1 ? I just don't
> > see
> > it.
> >
> > <echo> confused ${confused} </echo>
> >
> > <condition property="retest6" value="3" else="6">
> >
> > <equals arg1="${confused}" arg2="1" />
> >
> > </condition>
> >
> > <echo> retest ${retest}</echo>
> >
> >
> >
> > _recheck:
> >     [echo]  confused 1
> >     [echo]
> > Condition false; setting retest6 to 6
> > Setting project property: retest6 -> 6
> > Property "retest" has not been set
> >     [echo]  retest ${retest}
> > Property "retest" has not been set
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message