ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Jackson" <foamd...@gmail.com>
Subject Re: Redirecting <javac> compile errors
Date Thu, 17 Jan 2008 13:54:11 GMT
Hi,
> >>> and Java 1,3-compatible language features...it has to compile on older
> >>> versions. What we can do is have a directory of java6+ code that isnt
> >>> built on Java <6.
> >> I do not think that the ability to compile ant on < java5 is necessary.
> >>
> > The reaon I think this is that the resultant output will not be a
> > complete ant product.
>
>
> ooh, now there's an interesting thought. Java5+ only but test on Java
> 1.3, 1.4, 6.0, 6.4, harmony, java7...

It'd be nice if the tests passed at least on 1.3, but I think we need
to take a vote on it soon.

I've been really snowed under over christmas, so the release of 1.7.1
which I wanted to get out the door has been delayed.  If we cannot get
a clean test run for 1.3 (and yet 1.4+ is fine), then we need to
decide if we ship what we have but state clearly that it's only
'supported' on 1.4+ vms (or at least we state that features X,Y,Z may
not work on 1.3).

Thanks,
Kev

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message