ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Barry Pape" <bp...@netspend.com>
Subject environment attribute
Date Fri, 04 Jan 2008 20:25:42 GMT
Howdy all,

Hopefully this is a quick and easy question.  Is the environment
attribute of the property task supported on Solaris?  I've been trying
to use ${env.HOSTNAME} but it doesn't appear to resolve.

For instance:
    <target name="hostname ">
        <property environment="env"/>
		  <property name="hostname" value="${env.HOSTNAME}"/>
        <echo>Using ${hostname} for host name</echo>
    </target>

Which results in:
$ ant hostname
Buildfile: build.xml

hostname:
     [echo] Using ${env.HOSTNAME} for host name

BUILD SUCCESSFUL
Total time: 2 seconds

Any help is much appreciated.
Barry

And Happy New Year to all!



-----------------------------------------
Confidentiality Notice!
This electronic transmission and any attached documents or other
writings are confidential and are for the sole use of the intended
recipient(s) identified above. This message may contain information
that is privileged, confidential or otherwise protected from
disclosure under applicable law. If the receiver of this
information is not the intended recipient, or the employee, or
agent responsible for delivering the information to the intended
recipient, you are hereby notified that any use, reading,
dissemination, distribution, copying or storage of this information
is strictly prohibited. If you have received this information in
error, please notify the sender by return email and delete the
electronic transmission, including all attachments from your
system.


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message