ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Z W" <mpc8...@gmail.com>
Subject Re: sshexec and rexec hung
Date Thu, 31 Jan 2008 00:48:48 GMT
Rob
I didn't try that. I decided to take Chuck H. suggestion to kill the parent
process of the child process that <rexec> uses. It seems to work now.

Appreciate your response.

On Jan 30, 2008 3:33 PM, Anderson, Rob (Global Trade) <Rob.Anderson@nike.com>
wrote:

> I think this really depends on what you are executing with your shell
> script. Do the same scripts hang when you execute outside ant, using
> rexec or ssh? Try using nohup and be sure to background any processes
> you start.
>
> -Rob A
>
> -----Original Message-----
> From: Z W [mailto:mpc8250@gmail.com]
> Sent: Tuesday, January 29, 2008 7:24 PM
> To: Ant Users List
> Subject: sshexec and rexec hung
>
> Hi
>
> I've been trying to get my shell scripts to work with rexec and sshexec.
> My experience seems to indicate to me that both tasks don't seem to hang
> when executing shell scripts
> after exporting env variables with . ./profile.
>
> Is that everyone's experience or perhaps it's just me.
> I don't have much success trying to kill the parent process of the
> <rexec>
> on a remote host.
> My research shows that <rexec> basically issues sh -c <command>
> Is there a workaround to get out of the task at the end of shell script
> execution ?
> Even exit statement within shell script doesn't solve this.
>
> thanks
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message