ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jpyork <jp_y...@hotmail.com>
Subject Ant saving property file settings in memory?????
Date Fri, 25 Jan 2008 21:55:23 GMT

Ok, I would like to say thanks to everyone who has helped with the last two
postings I have had and hopefully this will be the last one for my issue.

Below is what I have setup:

<property file="result.properties"/>

	<target name="buildresults" > 		
              <if>     <equals arg1="${buildresults}" arg2="failed" /> 				
                   <then>  
                        <fail message="test fail test fail" /> 	
		   </then> 				
                   <else> 				
                           <echo message="success success" /> 			
                   </else> 		
              </if> 	
          </target>

This code works, but my final issue is that it seems ant store what
buildresults is set to at the start of the build and in my code I have that
setting changing and there fore it does not spit out the correct result.  So
right now if buildresults gets changed to successful in the middle of my
script and it was set to failed when it started the end result is that it
fails, when it should be successful.  Same applies when I start up the
script and the beginning setting is successful and it gets changed to
failed, it spits out "success success" instead of failing.

Any way around this?
-- 
View this message in context: http://www.nabble.com/Ant-saving-property-file-settings-in-memory------tp15097566p15097566.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message