ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knuplesch, Jürgen <>
Subject Rmic problems
Date Thu, 24 Jan 2008 09:00:09 GMT
Hi everybody,

I come across with a problem with rmic. 
I might have found sth. Like a bug or mysterios behaviour of Ant 1.7.

I was working wit Ant 1.6.5 and still do. But my Eclipse DIE changed to ANT 1.7.

If I run the following rmic task:

    <rmic base="${dope.rmic.dest}"
      <compilerarg value="-v1.2"/>
      <patternset refid="rmic" />

 I get errors like:
: Class de.... already defined in D:\

The compile ist still successfull, but the build stops.

If I run it a second time, it works.

If i run it with 1.6.5 it works fine.

The problem is my compilerarg that duplicates the stubversion argument. If I delete it like

    <rmic base="${dope.rmic.dest}"
      <patternset refid="rmic" />

Then everything is fine with Ant 1.7

My guess is, that the rmic-Task does sometimes two compiles if both arguments (stubversion
and compilerarg value="-v1.2") are included. The first compile works, but the second compile
ist shocked, that the stubs are already there and quits the whole build-process.

1.7 is always setting the stubversion attribut (1.6.5 not!). So the problem appears as well,
when you only use the compilerarg.

Is this the truth or do I have a different problem?



Jürgen Knuplesch          
icon Systemhaus GmbH                Tel. +49 711 806098-275
Sophienstraße 40                    
D-70178 Stuttgart                   Fax. +49 711 806098-299

Geschäftsführer: Uwe Seltmann
HRB Stuttgart 17655
USt-IdNr.: DE 811944121 

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message