ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chuck Holzwarth <chuck_holzwa...@yahoo.com>
Subject RE: CVS task failure: cannot rename
Date Thu, 27 Dec 2007 14:11:57 GMT
Judy,
Look at the ant exec task. You may find something by executing an "ls -l" of the directory
and then the directory and file string. You also may want to issue a umask command. It is
possible that while your ID has write permission, ant has been restricted, this could be the
case if the setuid bit is set on the ant executable.

Judy Anderson <JAnderson@rocketsoftware.com> wrote: I have done some more experimentation
with my problem.  It only happens on binary files (flag "-kb").  CVS is doing a different
kind of update that involves delete/rename.  I tried using  on cvs with no help.

It seems that, although I can "del" such a file manually, I cannot use ant's  task on one.
 So perhaps the problem is unrelated to CVS (well, excepting that the file was created by
CVS.)



   [delete] Deleting: c:\bt\mainline\bundle\bundle.jar

BUILD FAILED
build.xml:9: Unable to delete file c:\bt\mainline\bundle\bundle.jar

So, now I wonder if there's some weirdness within Ant about user permissions.  I can delete
a file I created by hand.  I cannot see any interesting difference in the Properties dialog
for either of these files in the explorer.  (The CVS created files have a "Summary" tab, but
my files don't.  It is blank.)  I'm really mystified.  I wish that I had the Windows error
code that led the  task to decide it could not delete the file.

-----Original Message-----
From: Judy Anderson [mailto:JAnderson@rocketsoftware.com]
Sent: Monday, December 24, 2007 3:53 PM
To: user@ant.apache.org
Subject: CVS task failure: cannot rename

I am a new user of ANT, and the first problem I've been unable to solve on my own is a CVS
problem.  (I didn't construct the build.xml file myself; I was handed an incomplete project,
on which I'm trying to come up to speed.)

   

   
    
    
     
...

  
    
  

Results in:
      [cvs] cvs [checkout aborted]: cannot rename file .new.emp-common.jar to emp-common.jar:
File exists

BUILD FAILED

However, when I use CVS update directly it works just fine.

The mentioned log file has a nice U line for the mentioned file (though as you see it didn't
fully get updated.)  I passed in -Dcvs.quiet=false but that just showed me "[cvs] cvs checkout:
Updating" lines for each prior directory, as one would expect.

Searching for similar error messages found me other people who had cannot renames with Permission
Denied, but that's not my problem.  One person with CVS problems recommended using an EXEC
task instead, which I'm considering, but wanted to see if there was any suggestion to how
to debug this using the CVS task.

Extremely strangely, .java files got updated when I ran it on a different package.  Now, unfortunately,
I can't make spurious changes to the repository in order to experiment to fins out if it's
only .jars, or only THAT .jar, or whatever.  But it's very worrisome to have an unexplained
failure in the build -- when this stuff goes live it'll be very bad to have it break at midnight
like this!

I'm using Windows XP; I think the CVS repository is on a unix machine, but I don't honestly
know (and I don't have access to that machine).  I have Ant 1.7.0.  What could have gone wrong
with the CVS task, and what can I do to get more information about the problem?  I hate mysterious
messages!

Judy Anderson
Rocket Software
janderson@rocketsoftware.com

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org





Thank you,
Chuck Holzwarth
(804) 403-3478 (home)
(540) 335-3171 (cell)
       
---------------------------------
Looking for last minute shopping deals?  Find them fast with Yahoo! Search.
Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message