ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jiechu <jiechul...@hotmail.com>
Subject Re: Error starting modern compiler
Date Mon, 17 Dec 2007 08:37:21 GMT

I have resolved this. Please check the enviroment settings of your machine
nad make sure if the JDK version matchs tools.jar.
To a norther word, sometimes you can leave %CLASSPATH% empty and point it in
a bat file.


Jacky-9 wrote:
> 
> Hi guys,
> 
> I encounter this error when trying to build my project (it works fine 
> previously):
> 
> BUILD FAILED
> /www/dist/production/common/build.xml:78: Error starting modern compiler.
> 
> Line 78 is:
> 
> <javac destdir="classes" debug="on" source="1.3" target="1.3" 
> encoding="UTF-8">
> 
> I have tried:
> <javac destdir="classes" debug="on" source="1.4" target="1.4" 
> encoding="UTF-8">
> <javac destdir="classes" debug="on" source="1.5" target="1.5" 
> encoding="UTF-8">
> 
> The error is still the same.
> 
> I upgraded ant from 1.6.5 to 1.7.0 and the error persists.
> Any ideas guys?
> 
> Linux dev.hkdnr.hk 2.4.20-021stab028.17.777-smp
> java version "1.5.0_10"
> Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_10-b03)
> Java HotSpot(TM) Client VM (build 1.5.0_10-b03, mixed mode, sharing)
> 
> 
> Thanks.
> 
> -- 
> Warm regards,
> Jacky Wong
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Error-starting-modern-compiler-tp9450044p14370152.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message