ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Stefan Bodewig or Magesh Umasankar, please kindly help: Ant 1.5 to 1.7 problem.
Date Mon, 19 Nov 2007 05:20:19 GMT
On Sun, 18 Nov 2007, Major shao <majorshao@gmail.com> wrote:

>     I am in the process to upgrade a project building using ant1.5.1
>     to ant1.7 directly. There is a ant151patch.jar file used in this
>     project since a while back. I have to comment out this jar file
>     otherwise i would get all sorts of error like
>     java.lang.ExceptionInInitializerError; i am wondering whatever
>     this jar took care of for ant151 is already included in ant1.7
>     (without the need of that kind of patch), is that accurate?

I have no idea what this jar might do and I've never heard of a jar
like this.

I'd simply suggest you try building with 1.7 and stick with it if it
works, which it most probably will.

You could compare your Os.java class to the one found in subversion
and try to trace back changes.

1.5.1 is very old and I think it predates Windows XP - and I vaguely
recall we had problems detecting XP as a "modern" windows (as opposed
to win9x).  Yes, Ant 1.7 works fine on XP.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message