ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Weintraub" <qazw...@gmail.com>
Subject Re: Ant 1.5 to 1.7 problem.
Date Fri, 09 Nov 2007 19:18:17 GMT
What version of Java are you using? With Ant1.7.0, I think you need
Java 1.4 or later.

On 11/9/07, Major shao <majorshao@gmail.com> wrote:
>  Hi, everyone
>
>  i am trying to upgrade the project from ant1.5.1 to ant1.7.0
>
>  it gave error build_config.xml:151: java.lang.ExceptionInInitializerError
>
>  the line 151 of that xml is a uptodate task. Any idea why i got the
>  error? Please kindly help.
>  Your reply is highly appreciated.
>
>  <target name="check.db.schema.up.to.date" >
>          <uptodate property="db.schema.up.to.date"
>  targetfile="${get.dbversion.build.dir}/src/dbinfo.properties" >
>              <srcfiles dir= "${db.root.dir}" >
>                  <include name="DBInfo.java" />
>                  <include name="GetDbInfo.java" />
>              </srcfiles>
>          </uptodate>
>  </target>
>
>
>  I tried to not to use the ${get.dbversion.build.dir}, it still does not
>  work. Though it works if i use
>  <uptodate property="db.schema.up.to.date" srcfile="test1.java"
>  targetfile="dbinfo.properties" >
>  i cannot find out why.
>  And, it looks like i have more similar issues in the other following
>  lines in the xml. I cannot just change everything to not having the
>  path variable. Please help!
>
> Thanks
>
> Richard
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>


-- 
--
David Weintraub
qazwart@gmail.com

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message