ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Major shao" <majors...@gmail.com>
Subject Re: Ant 1.5 to 1.7 problem.
Date Fri, 09 Nov 2007 21:12:12 GMT
java version "1.4.2_05"

Thanks for reply, I really need help on this!

I suspect it's caused by the ant 1.7 does not take the dir path property ${
get.dbversion.build.dir} in the uptodate task. But it still failed if i
replace it with absolute path.
I do not understand. The forward slash or backward slash should not matter,
right?

And, this target is in an embedded xml. That means, the target is called
from the build.xml (using   &build_config;) which has the build_config.xml
(which has this uptodate target).

When I echo the property inside this target right before the task uptodate,
it shows correct path. But it still fails and complains the uptodate task.


On 11/9/07, David Weintraub <qazwart@gmail.com> wrote:
>
> What version of Java are you using? With Ant1.7.0, I think you need
> Java 1.4 or later.
>
> On 11/9/07, Major shao <majorshao@gmail.com> wrote:
> >  Hi, everyone
> >
> >  i am trying to upgrade the project from ant1.5.1 to ant1.7.0
> >
> >  it gave error build_config.xml:151:
> java.lang.ExceptionInInitializerError
> >
> >  the line 151 of that xml is a uptodate task. Any idea why i got the
> >  error? Please kindly help.
> >  Your reply is highly appreciated.
> >
> >  <target name="check.db.schema.up.to.date" >
> >          <uptodate property="db.schema.up.to.date"
> >  targetfile="${get.dbversion.build.dir}/src/dbinfo.properties" >
> >              <srcfiles dir= "${db.root.dir}" >
> >                  <include name="DBInfo.java" />
> >                  <include name="GetDbInfo.java" />
> >              </srcfiles>
> >          </uptodate>
> >  </target>
> >
> >
> >  I tried to not to use the ${get.dbversion.build.dir}, it still does not
> >  work. Though it works if i use
> >  <uptodate property="db.schema.up.to.date" srcfile="test1.java"
> >  targetfile="dbinfo.properties" >
> >  i cannot find out why.
> >  And, it looks like i have more similar issues in the other following
> >  lines in the xml. I cannot just change everything to not having the
> >  path variable. Please help!
> >
> > Thanks
> >
> > Richard
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> > For additional commands, e-mail: user-help@ant.apache.org
> >
> >
>
>
> --
> --
> David Weintraub
> qazwart@gmail.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message