ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 김동광 <eli...@nhncorp.com>
Subject Ant file.encoding problem.
Date Fri, 09 Nov 2007 07:03:53 GMT
Dear everyone.

 

I have been used ant 1.7.0 for running my program on linux (redhat. 2.6.9-42.0.10.ELsmp)

However, I have a some problem to process file.encoding.

 

My problem is..

A original file was written based on MS949 encoding. My program is working to read this file
and write another file which was also MS949.

This compile was completed and I execute “java -Dfile.encoding=MS949 Test”. It was good
work.

 

But, I wrote build.xml ;

------------------------------------------------

<target name="test"

        description="classes">

        <echo>ANT ENCODING : ${file.encoding}</echo>

        <java classname="Test">

            <sysproperty key="file.encoding" value="MS949"/>

            <classpath location="." />

        </java>

</target>

------------------------------------------------

# ant -Dfile.encoding=MS949 test

ANT ENCODING : MS949

 

This result was error……… output file’s data was broken such as “?????” .

 

I couldn’t understand and recognize why this problem happen… I have just thought a same
result from java and ant.

 

Do you have any solution..???

 

Regards…

 

----------------------------------------------------------------

 NHN Corporation

 김 동 광 ( Kim DongKwang )

 경기도 성남시 분당구 서현동266-1번지 분당퍼스트타워 13층

 Office : 031-600-6079 , Mobile : 011-9353-3552

 E-mail : elight@nhncorp.com

----------------------------------------------------------------

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message