ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Styles" <styles...@gmail.com>
Subject Websphere 6 Ant Tasks can't be found....
Date Thu, 08 Nov 2007 18:11:16 GMT
Hi,

I'm using Cruise Control and Websphere 6 to build and deploy my application
to a remote server, but when I execute the build/deploy, I get and *Ant
Error Message*... My websphere ant tasks can't seem to be found.... If I
comment out the taskdefs, the build portion works fine, but I need the
websphere ant tasks for my deployment... Here's the error message: *Ant
Error Message:*C:\CruiseControl\projects\mib\MIB_2.X_FWD_DEV_AIX-WAS-DB2\EP_US_PSO_2.X\build\build.xml:72:
taskdef class com.ibm.websphere.ant.tasks.StopServer cannot be found....
Below, is how I my have my Websphere Home and taskdefs defined in my
build.xml... Is my Websphere Home defined correctly in order for the
websphere ant tasks to be found...??? I'd appreciate it if someone could
point me in the right direction...

Thanks


<property name="ws.home" value="C:/Progra~1/IBM/WebSph~/AppServer"/>


<path id="lib.path">
    <pathelement location="${ws.home}/lib/*.jar"/>
</path>

<taskdef name="wsStopServer"
        classname="com.ibm.websphere.ant.tasks.StopServer">
    <classpath refid="lib.path"/>
</taskdef>

<taskdef name="wsStartServer"
        classname="com.ibm.websphere.ant.tasks.StartServer">
    <classpath refid="lib.path"/>
</taskdef>

<taskdef name="wsUninstallApp"
        classname="com.ibm.websphere.ant.tasks.UninstallApplication">
    <classpath refid="lib.path"/>
</taskdef>

<taskdef name="wsInstallApp"
        classname="com.ibm.websphere.ant.tasks.InstallApplication">
    <classpath refid="lib.path"/>
</taskdef>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message