ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darin Swanson <Darin_Swan...@us.ibm.com>
Subject Re: AW: Eclipse still using Ant 1.6.5 because of bug in Ant 1.7.0
Date Fri, 26 Oct 2007 00:20:56 GMT
Eclipse 3.3.* ships with Ant 1.7.0

We were able to come up with a workaround for the Ant problem on Windows 
and decided to ship with the known problem for Mac and Unix machines as 
outlined in 
https://bugs.eclipse.org/bugs/show_bug.cgi?id=187993 where it also 
outlines that this problem is fixed in the Ant 1.7.1 stream.

We will move to the Ant 1.7.1 release as soon as we can get our hands on 
it and it makes it through the Eclipse IP review.
Unfortunately this is not looking good for Eclipse 3.3.2 as we are running 
out of time.

Of course a user can point the Eclipse Ant home to a new Ant release and 
make use of Ant 1.7.1 as soon as it is released if they so desire.

Thanks for the bandwidth
Darins
Eclipse Platform Ant team lead




<Jan.Materne@rzf.fin-nrw.de> 
10/25/2007 06:32 AM
Please respond to
"Ant Users List" <user@ant.apache.org>


To
<user@ant.apache.org>
cc

Subject
AW: Eclipse still using Ant 1.6.5 because of bug in Ant 1.7.0






Also that statement does not mean that Eclipse ships an older version of 
Ant.
If you have a look, you'll see that it's 1.7.0.

$ cd ECLIPSE_HOME
$ cd plugins

--> 1.hint: the name of the plugin is org.apache.ant_1.7.0.v200706080842

$ cd org.apache.ant_1.7.0.v200706080842
$ cd bin
$ .\ant -version

--> 2.hint: Apache Ant version 1.7.0 compiled on December 13 2006
 
Tried with Eclipse JEE
  Version: 3.3.0
  Build id: I20070621-1340


Jan



>-----Urspr√ľngliche Nachricht-----
>Von: Peter Reilly [mailto:peter.kitt.reilly@gmail.com] 
>Gesendet: Donnerstag, 25. Oktober 2007 14:37
>An: Ant Users List
>Betreff: Re: Eclipse still using Ant 1.6.5 because of bug in Ant 1.7.0
>
>Ok,
>It is fixed in SVN
>http://issues.apache.org/bugzilla/show_bug.cgi?id=42222
>and will be in ant 1.7.1
>
>Peter
>
>
>On 10/25/07, Peter Reilly <peter.kitt.reilly@gmail.com> wrote:
>> What is the corresponding Ant Bugzilla report?
>>
>> Peter
>>
>> On 10/25/07, Hans Schwaebli <hans_schwaebli@yahoo.com> wrote:
>> > Eclipse seems to be still using Ant 1.6.5 because of a Ant bug.
>> >
>> >   Why does the Ant team not fix it so that Eclipse can use 
>the new Ant version?
>> >
>> >   I quote: "Due to a bug in Ant 1.7.0, Ant builds will 
>fail with an IllegalArgumentException if the Eclipse 
>installation is in a location with spaces in the path. 
>Embedded usage of Ant builds, such as plug-in export will also 
>fail. See bug 187993 for possible workarounds."
>> >
>> > 
>http://www.eclipse.org/eclipse/development/readme_eclipse_3.3.1.html
>> >
>> >  __________________________________________________
>> > Do You Yahoo!?
>> > Tired of spam?  Yahoo! Mail has the best spam protection around
>> > http://mail.yahoo.com
>>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>For additional commands, e-mail: user-help@ant.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message