ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From supareno <reno.rkc...@free.fr>
Subject keytool with ant
Date Tue, 16 Oct 2007 13:59:17 GMT
hi guys,

i tried this with and under ubuntu 7.04 with a jdk 1.5 and eclipse...

...
<!--
command line:
keytool -genkey -alias <alias> -keystore <certifname> -keypass 
"<keypass>" -dname "<dname>" -storepass "<storepass>"
-->
<target name="keytoolexec" depends="jarfile">
   <exec dir="." executable="keytool" os="Linux" failonerror="true">
             <arg value="-genkey "/>
             <arg value="-alias ${alias} />
             <arg value="-keystore ${keystore_name}" />
             <arg value="-keypass ${keypass}" />
             <arg value="-dname ${dname}" />
             <arg value="-storepass ${storepass}" />           
  </exec>
</target>
...

the command line works well but with ant it fails !!
the error is the "-alias" argument...
i tried with:

...
<arg value="-genkey  -alias ${alias} -keystore ${keystore_name} -keypass 
${keypass} -dname ${dname} -storepass ${storepass}" />
...
and it fails again :-(

did anybody try this and did it without error??

frederic

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message