ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vijay Aravamudhan <avij...@gmail.com>
Subject Re: My first build with ant failed
Date Tue, 09 Oct 2007 03:59:21 GMT
Your target for compile is incorrect. It should read:

<target name="compile" depends="clean, init, copy-resources">
        <javac srcdir="${sourcedir}" destdir="${targetdir}" classpathref="libraries"/>
    </target>

You are missing " in two places.

hth,
Vijay


Mohammad Khan wrote:
> below is the part of my build.xml
>
>    <target name="clean">
>         <delete dir="${targetdir}"/>
>     </target>
>
>     <target name="init" depends="clean">
>         <mkdir dir="${targetdir}"/>
>     </target>
>
>     <target name="copy-resources" depends="clean, init">
>         <copy todir="${targetdir}">
>             <fileset dir="${sourcedir}">
>                 <exclude name="**/*.java"/>
>             </fileset>
>         </copy>
>     </target>
>
>     <target name="compile" depends="clean, init, copy-resources">
>         <javac srcdir="${sourcedir} destdir=${targetdir}"
> classpathref="libraries"/>
>     </target>
>
>
>
> ant returned:
>
> BUILD FAILED
> srcdir "/home/user/project/src destdir=/home/user/project/bin" does not
> exist!
>
> I see both src and bin directory exist in my project root.
> Would anybody give a light on it?
>
> Thanks,
> Mohammad
>
>
>   

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message