ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Middleton" <stephen.middle...@codebaby.com>
Subject Exec is failing, command line works fine
Date Tue, 02 Oct 2007 20:14:11 GMT
Hi everyone,

I'm having a problem with an executable that seems to work fine from the
command line, but does not work with the ant "exec" task.  

If I type this into the command line, it works no problem:
 
emake -B -f mymakefile.mak


But if I use the following build.xml file with Ant:

<project default="BuildEureka">

    <target name="BuildEureka" depends="">
    	<exec executable="emake" failonerror="true">
    	   <arg line="-B -f psbase.mak"/>
    	</exec>
    </target>

</project>


...I end up with the following output:

Buildfile: build.xml

BuildEureka:
	[exec] MAKE Version 5.2  Copyright (c) 1987, 2000 Borland

	[exec] ** error 1 ** deleting Debug_Build

BUILD FAILED
...

I have also tried to use the "value" type arg elements, but the result is
the same.  For those of you that are interested, the executable I'm trying
to run is EurekaLog's "emake.exe", intended to be used in place of Borland
"make.exe"  Not sure if it has anything to do with this issue, but when I
try to redirect the output of emake.exe to a file, it says "The handle is
invalid."

Does anyone know what's going on here?

Any help would be greatly appreciated -- thanks!

- Steve


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message