ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Wilkinson" <swilk...@uoguelph.ca>
Subject RE: problems with ant optional tasks
Date Wed, 26 Sep 2007 15:00:27 GMT
Hi there and thank you for responding;
I downloaded and installed ant-optional-1.6.5-20.3.i586.rpm
Which is the closest version I could find to ant-1.6.5-4jpp.noarch.rpm,
it just contained ant-antlr

Ant -diagnostics still says optional tasks: not available 

The install put the ant-antlr jar into /usr/share/java rather than
usr/share/ant/lib so I tried copying them there but didn't help.

I tried forcing the library with ant -lib /path but same result. 
Any other suggestions?
Thanks again for your time
Stephen
 

-----Original Message-----
From: Steve Loughran [mailto:stevel@apache.org] 
Sent: September 26, 2007 6:08 AM
To: Ant Users List
Subject: Re: problems with ant optional tasks



Stephen Wilkinson wrote:
> Hi there, I'm pretty much totally new to linux and am having some
build
> problems with Dspace which I believe is because I don't have my Ant
> optional tasks working.


aah DSpace.

> 
> Basics I'm using Suse Linux Enterprise Server version 10 with sp 1
> 
> I downloaded and installed java - jdk-6u2-linux-i586.rpm
> 
> As well as "ant-1.6.5-4jpp.noarch.rpm" and
> "ant-apache-regexp-1.6.5-4jpp.noarch.rpm"
> 
> I also installed postgresql 8.1
> 
> I downloaded dspace source tarball
> 
> When I run ant fresh_install from the dspace download directory I get
a
> build failed error:88 no regular matching expression found (that's why
I
> downloaded and installed "ant-apache-regexp-1.6.5-4jpp.noarch.rpm",
but
> didn't help)



> replaceregexp : Not Available


Try grabbing ant-optional as well, which should contain the missing 
tasks. You shoudn't need any extra libraries for a java6 jvm, as it has 
built in regexp code.
-- 
Steve Loughran                  http://www.1060.org/blogxter/publish/5
Author: Ant in Action           http://antbook.org/

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message