ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "TSD Contractor2" <TSDContract...@sis.tv>
Subject RE: Optional scp task does not accept remote paths with the '@' symbol in them
Date Fri, 28 Sep 2007 12:19:48 GMT
 
Tell that to IBM!! (Who surely should no better!) I'm using the scp task
to copy files from a remote IBM WebSphere MQ installation and have no
control over the remote path! As I said, it worked previously (in Ant
1.6.5) so I'm concerned that a bug has been introduced into Ant 1.7
which needs resolving.

Richard Lund


-----Original Message-----
From: Anderson, Rob (Global Trade) [mailto:Rob.Anderson@nike.com] 
Sent: 27 September 2007 18:41
To: Ant Users List
Subject: RE: Optional scp task does not accept remote paths with the '@'
symbol in them

Probably not the advice you are looking for, but I'll share it anyway...

I strongly recommend against using any of the following characters in
file names or pathnames.
@$#%*!~()\|/?`,;:<> (perhaps others as well)

Programming languages and shells often treat these characters
differently than alpha-numeric characters. Programmers know this, and
often write their programs without anticipating that these characters
might be used in file names and path names. I recommend avoiding such
characters in file and path names to save yourself from this, and other
such headaches.

-Rob Anderson

> -----Original Message-----
> From: TSD Contractor2 [mailto:TSDContractor2@sis.tv]
> Sent: Thursday, September 27, 2007 3:43 AM
> To: user@ant.apache.org
> Subject: Optional scp task does not accept remote paths with the '@' 
> symbol in them
> 
> APOLOGIES FOR THE DOUBLE POSTING (OUTLOOK SCREWED UP THE ORIGINAL)
> 
> Tried running the following command using Ant 1.7:
> 
> <scp
> file="mqm@MQ-GATEWAY-INT.sis.tv:/var/mqm/qmgrs/LIGWGWAY1/@ipcc
> /AMQCLCHL.
> TAB" localTodir="client_conn_tables" password="blah" trust="yes"/>
> 
> And get the following:
> no remote path in
> mqm@MQ-GATEWAY-INT.sis.tv:/var/mqm/qmgrs/LIGWGWAY1/@ipcc/AMQCLCHL.TAB
> 
> This used to work in Ant 1.6.5!!
> 
> It looks like some over-zealous checks are being made on the remote 
> path which get confused by the second '@' symbol in the remote path. 
> It works fine for paths without this second symbol. Is there a fix for

> this out already?
> 
> *************************************************************
> Satellite Information Services Limited Registered Office: 
> 17 Corsham Street London N1 6DR, Company No. 4243307
> 
> The information in this e-mail (which includes any files transmitted 
> with it) is confidential and is intended for the addressee only. 
> Unauthorised recipients are required to maintain confidentiality.  If 
> you have received this e-mail in error please notify the sender 
> immediately, destroy any copies and delete it from your computer 
> system.
> *************************************************************
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org For additional

> commands, e-mail: user-help@ant.apache.org
> 
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org For additional
commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message