ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Saladin Sharif <al_zaw...@yahoo.com>
Subject Re: ant script just hang when checking out of CVS [Similar problem with cvstagdiff]
Date Wed, 26 Sep 2007 00:38:22 GMT

--- Robert Clark <robert.clark@quest.com> wrote:
>
> Setting up SSH so that it does not require a
> password, yet is still 
> secure.

I just found out from my system admin that I cannot
setup private/public key for my machine to connect to
the CVS server, due to internal security policies.

But anyway, it just occured to me and I am wondering
whether the problem that I am having with cvstagdiff
has anything to do with ssh waiting for the password.

After all I am perfectly able to execute the following
from my ANT script:

<cvs package="myProject" dest="${basedir}/temp" />

The above command works and it is able to successfully
checkout the myProject package into the temp folder.

On the other hand, executing the cvstagdiff in the
same ANT script does not work and it just hangs:

<cvstagdiff 
    destfile="${basedir}/temp/tagdiff.xml"
    package="myProject"
    startDate="09/15/2007"
    endDate="09/24/2007"
    failonerror="true"
    quiet="false"
/>

Recall from my previous e-mail that I am setting the
username and password in the CVSROOT environment
variable:

CVSROOT=:ssh;username=MyUserName;password=MyPassword;hostname=some.servername.com:/opt/cvs

So I don't understand why the cvs and the cvstagdiff
tags act differently.  Why does the cvs tag work with
the password being set in the CVSROOT environment
variable, while the cvstagdiff tag doesn't???

-Saladin


--- Saladin Sharif <al_zawiah@yahoo.com> wrote:

> 
> I am actually having a similar problem; when I try
> to
> use the cvstagdiff tag in my ANT script it hangs.
> 
> <cvstagdiff 
>     destfile="${basedir}/temp/tagdiff.xml"
>     package="myProject"
>     startDate="09/15/2007"
>     endDate="09/24/2007"
>     failonerror="true"
>     quiet="false"
> />
> 
> NOTE: my CVSROOT is set as an environment variable
> as
> such
> 
> set
>
CVSROOT=:ssh;username=MyUserName;password=MyPassword;hostname=some.servername.com:/opt/cvs
> 
> I have tried running my ant script in verbose mode;
> it
> gives me the following output before it hangs
> 
> cvs:
> [cvstagdiff] Executing 'cvs' with arguments:
> [cvstagdiff] 'rdiff'
> [cvstagdiff] '-s'
> [cvstagdiff] '-D'
> [cvstagdiff] '09/15/2007'
> [cvstagdiff] '-D'
> [cvstagdiff] '09/24/2007'
> [cvstagdiff] 'myProject'
> [cvstagdiff] 
> [cvstagdiff] The ' characters around the executable
> and arguments are
> [cvstagdiff] not part of the command.
> 
> 
> I've also tried executing the equivalent cvs command
> directly from the command prompt, and it works just
> fine:
> 
> cvs rdiff -s -D 09/15/2007 -D 09/24/2007 myProject
> 
> 
> But when I execute the cvstagdiff from my ANT script
> it just hangs.
> 
> Any ideas on how to get the cvstagdiff to work?
> 
> Thanks in advance,
> 
> -Saladin
> 





**********************************************************
* Saladin Sharif
* e-mail:  al_zawiah@yahoo.com
* Visit homepage @ http://gaia.ecs.csus.edu/~sharifs
**********************************************************


       
____________________________________________________________________________________
Boardwalk for $500? In 2007? Ha! Play Monopoly Here and Now (it's updated for today's economy)
at Yahoo! Games.
http://get.games.yahoo.com/proddesc?gamekey=monopolyherenow  

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message