ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Hatton" <khat...@axiomsystems.com>
Subject RE: Is & a somehow special character to Ant?
Date Fri, 24 Aug 2007 08:15:29 GMT
You probably need to use the XML escape sequence "&amp;"

Hope this helps
Keith


-----Original Message-----
From: Krzysztof Kucybala [mailto:kkucybala@echo.fr] 
Sent: 24 August 2007 09:13
To: Ant Users List
Subject: Is & a somehow special character to Ant?


Hi,

I'm trying to use the exec task to issue a shell command, whose output 
to stderr and stdout I'd really like redirected to a file and the 
deleted, as it is not relevant and is corrupting my build report. So
this is what I run on the command line:

phpunit --log-xml somelog.xml MyCoolTest &>test.dump

On the shell it works fine, but when put to ant exec task I get this
error:

The entity name must immediately follow the '&' in the entity reference.

Can anyone please tell me how to get around this? I tried escaping the &

with \, but that's not working either :o( Thanks in advance for any
help.

Best regards,
Krzysztof

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message