ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Egorov" <vego...@bea.com>
Subject ant -lib seems not working on Linux RHEL 5
Date Tue, 03 Jul 2007 22:13:53 GMT
Hi Ant Users,

The Ant -lib option does not seem working on Linux RHEL 5.

I am in a directory, where I have ant-contrib-1.0b2.jar and the
following t.xml.

$ cat t.xml
<project>
  <taskdef resource="net/sf/antcontrib/antlib.xml" />
  <if><istrue value="true"/>
    <then><echo message="it works!"/></then>
  </if>
</project>

I run this using the -lib option.

$ ant -lib ant-contrib-1.0.b2 -f t.xml
Buildfile: t.xml
  [taskdef] Could not load definitions from resource
net/sf/antcontrib/antlib.xml. It could not be found.

BUILD FAILED 
  ... Could not create task or type of type: if.

The above t.xml works on a different platform.

Thank you,

--Vladimir

P.S. If I explicitly specify classpath in taskdef, it works on Linux
RHEL 5.

$ cat t.xml
<project>
  <taskdef resource="net/sf/antcontrib/antlib.xml"
           classpath="ant-contrib-1.0b2.jar"/>
  <if><istrue value="true"/>
    <then><echo message="it works!"/></then>
  </if>
</project>

$ ant -f t.xml
Buildfile: t.xml
     [echo] it works!

BUILD SUCCESSFUL

Notice:  This email message, together with any attachments, may contain information  of  BEA
Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,
 copyrighted  and/or legally privileged, and is intended solely for the use of the individual
or entity named in this message. If you are not the intended recipient, and have received
this message in error, please immediately return this by email and then delete it.

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message