ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r...@ryano.us
Subject Re: Difficulties Installing Ant
Date Thu, 19 Jul 2007 15:21:41 GMT
 Hi Clay,

It sounds like you have ant installed and ready to go.  Did you download
the binary zip bundle and unzip it?  If so I think you are ready to
roll.  By default when you invoke ant it looks for a build.xml file in
the current directory and runs the default target defined in that file. 
If you like you can specify a build file to process using the -f option
to ant.

I may be missing something.  hth.
--ryano

  ----- Original Message -----
  From: "Carter, Donald C (Genworth)"
  To: user@ant.apache.org
  Subject: Difficulties Installing Ant
  Date: Thu, 19 Jul 2007 11:02:38 -0400


  Hello,
  I'm trying to install ant and running into some frustrating problems.
  I
  setup the env variables and execute ant.bat as indicated by the
  install.html file in the docs, and the ant.bat execution fails due to
  a
  lack of a build.xml file. I checked and there is no build.xml file to
  be found in the ant directory. This is a copy of my output:

  c:\>set ANT_HOME=c:\apache-ant-1.7.0

  c:\>set JAVA_HOME=c:\Program Files\Java\jdk1.6.0_02

  c:\>set
  PATH=C:\cygwin\usr\local\bin;C:\cygwin\bin;C:\cygwin\bin;C:\cygwin\usr\X
  11R6\bin;c:\Oracle\Ora10g\bin;c:\Oracle\Ora10g\jre\1.4.2\bin\client;c:\O
  racle\Or
  a10g\jre\1.4.2\bin;c:\Program
  Files\CA\SC\CAWIN\;c:\WINDOWS\system32;c:\WINDOWS;
  c:\WINDOWS\System32\Wbem;c:\Program
  Files\CA\DSM\bin;c:\PROGRA~1\CA\SC\CAM\bin;c
  :\Program Files\Microsoft SQL Server\90\Tools\binn\;c:\Program
  Files\Embarcadero
  \Shared;c:\apache-ant-1.7.0\bin

  c:\>cd apache-ant-1.7.0\bin

  c:\apache-ant-1.7.0\bin>ant.bat
  Buildfile: build.xml does not exist!
  Build failed


  Has anyone seen similar problems when installing ant? Any help would
  be
  greatly appreciated.

  Clay Carter

Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message