ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knuplesch, Jürgen <Juergen.Knuple...@icongmbh.de>
Subject AW: Problem with Ant and CVS?
Date Wed, 01 Aug 2007 06:21:00 GMT
Hi Simon,

I always found it better to call CVS via ANT using commandline and argument rather than command.
So maybe you want to try sth. Similar to this:

   <cvs cvsroot="${cvs.root}" cvsrsh="${cvs.rsh}" dest="${cvs.exportboxbase}" failonerror="true">
      <commandline>
        <argument value="checkout" />
        <argument value="-r" />
        <argument value="${cvs.branchtag}" />
        <argument value="${cvs.project}" />
      </commandline>
      <!-- Projekt/Modul ins Exportverzeichnis auschecken -->
      <!-- das steht noch im alten Build zusätzlich: cvs quiet="true" -->
    </cvs> 


Hope this helps... 

-- 
Jürgen Knuplesch                    www.icongmbh.de
icon Systemhaus GmbH                Tel. +49 711 806098-275
Sophienstraße 40                    
D-70178 Stuttgart                   Fax. +49 711 806098-299

Geschäftsführer: Uwe Seltmann
HRB Stuttgart 17655
USt-IdNr.: DE 811944121 
-----Ursprüngliche Nachricht-----
Von: Simon Renshaw [mailto:snakybastard@gmail.com] 
Gesendet: Montag, 30. Juli 2007 17:20
An: user@ant.apache.org
Betreff: Problem with Ant and CVS?

Hi,

I think I'm having some problems with Ant and CVS.

I'm currently setting up CruiseControl and they told me that the problem I'm having is an
issue between Ant and CVS so this is why I'm posting this here.

I'm using Ant 1.7.

Problem: CVS does not update correctly.

In the delegated build file in my work directory, I have the following lines for CVS:

<!-- Get the latest from CVS -->
<cvs command="-d :pserver:simon:179317@192.168.64.23:/usr/local/sceip
update TransactionsQueue"/>


When I look in the email report, I see the following:

Last log entry: Second test by Simon

This is the comment that I wrote when I did the latest commit but when I looked in the checkout
directory, I don't see the modifications that I made to a file.

So it look like it can see the new comments but it does not update the files.

So, what is wrong with my cvs command line?

If I run the command manually, it works.

Thanks!
Simon

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message