ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Weintraub" <qazw...@gmail.com>
Subject Re: Problem with <mail> task
Date Tue, 12 Jun 2007 01:10:11 GMT
I found the library dependency list at
<http://ant.apache.org/manual/install.html#librarydependencies>, and
it says that mail.jar must be in my path. I'll have to verify that. I
know that CruiseControl mail works, but maybe CruiseControl
distributed the mail.jar in its distribution.

I'll have to give that a try tomorrow when I get back at work.

On 6/11/07, Anderson, Rob (Global Trade) <Rob.Anderson@nike.com> wrote:
> I'm not sure what this means. I would check the dependencies required
> for the mail task, to ensure that they are in place.
>
> http://ant.apache.org/manual/index.html
>
> Also, search the user list archives, I have seen chatter about this in
> the past.
>
> I hope this helps.
>
> -Rob A
>
> > -----Original Message-----
> > From: David Weintraub [mailto:qazwart@gmail.com]
> > Sent: Monday, June 11, 2007 2:59 PM
> > To: Ant Users List
> > Subject: Problem with <mail> task
> >
> > I have a very straight forward build.xml file:
> >
> > <project name="test" default="test" basedir=".">
> >     <target name="test">
> >         <mail
> >             from="dweintraub@solbright.com"
> >             subject="Test Email"
> >             mailhost="192.168.128.100"
> >             user="dweintraub"
> >             password="xxxxxxxx"
> >             message="This is a test email"
> >             failonerror="true">
> >             <to name="David Weintraub"
> >                 address="dweintraub@solbright.com"/>
> >         </mail>
> >     </target>
> > </project>
> >
> > When I attempt to execute it, I get the following error message:
> >
> > test:
> >      [mail] Failed to initialise MIME mail:
> > javax/mail/MessagingException
> >
> > BUILD SUCCESSFUL
> >
> >
> > Which is strange because I set "failonerror" to "true".
> >
> > Any ideas? I am currently sending mail via CruiseControl and
> > that works (and where I got the parameters from) so I know
> > that it is possible to send email from this machine.
> >
> > If it's any help, here's the message from CruiseControl:
> >
> > Failed to initialise MIME mail:
> > org.apache.tools.ant.taskdefs.email.MimeMailer
> >
> > I am running Ant 1.7
> >
> > --
> > David Weintraub
> > qazwart@gmail.com
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@ant.apache.org For
> > additional commands, e-mail: user-help@ant.apache.org
> >
> >
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>


-- 
--
David Weintraub
qazwart@gmail.com

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message