ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kannan Ekanath" <kannan.ekan...@gmail.com>
Subject Unable to execute a command mysql with a < symbol
Date Fri, 15 Jun 2007 06:02:17 GMT
Hi,
ANT - 1.6.5
I am trying to execute the following command line from ANT
"D:\>mysql -u root -pwelcome --database=warranty < target/create-schema.sql"

Basically the create-schema sql file has to be loaded using mysql command. I
understand that there is a problem with "<" symbol in ant command line as
mentioned in http://ant.apache.org/faq.html#shell-redirect-1, Hence I tried,

<target name="execute.schema.script.cmd">
        <echo message="Executing schema script..." />
        <exec executable="mysql">
            <arg line="--user=root --password=welcome --database=wararnty
&lt; target/create-schema.sql" />
        </exec>
</target>

This dint do the job and gave me mysql usage information. Then I tried the
"-c" option that is specified in the link (Guess this is available only with
SHELL?)
<target name="execute.schema.script.cmd">
        <echo message="Executing schema script..." />
        <exec executable="mysql">
            <arg line='-c "--user=root --password=welcome
--database=wararnty &lt; target/create-schema.sql"' />
        </exec>
</target>

This gave me a mysql unknown option "-c".

Presently I am using <SQL> tag to actually create the schema, this being
JDBC indirectly takes a lot of time. I would like to reduce it. Any
suggestions?
-- 
Regards,
Kannan Ekanath

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message