ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dale Anson <dan...@grafidog.com>
Subject Re: <assert> broken in antcontrib 1.0b3 ?!
Date Sat, 09 Jun 2007 15:43:27 GMT
Hi,

Sorry for the late response.  Did you get an answer to this?  The assert 
task in antcontrib is based on the assert task from antelope.  You might 
try the antelope version, I've verified that you can nest an <echo> in 
it.  Here's a link to the jar with just the tasks:

http://antelope.tigris.org/files/documents/1409/11489/AntelopeTasks_3.4.2.zip.

Dale


Rebhan, Gilbert wrote:
> Hi,
>
> i tried the most actual version of antcontrib = 1.0b3
> but the assert task seem to be broken.
>
> <!-- Import AntContrib -->
>     <taskdef resource="net/sf/antcontrib/antlib.xml" />
> ...
> <property name="ant.enable.asserts" value="true"/>	
>
> <assert name="ant.enable.asserts" execute="true">
>         <echo>assert works ....</echo>
>         </assert>
>
>
> output with antcontrib 1.0b2
>
> [echo] assert works ....
>
> output with antcontrib 1.0b3
>
> Class net.sf.antcontrib.logic.Assert doesn't support the nested "echo"
> element.
>
>
> Any ideas how to make the assert task work with 1.0b3 ?
>
>
> Regards,
> Gilbert
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>   

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message