ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Saurabh Dave" <saurabh.d...@patni.com>
Subject RE: Mail failing in build.xml file
Date Tue, 12 Jun 2007 06:57:49 GMT
Download the Activation.jar and mail.jar and copy in ant Lib folder... 

-----Original Message-----
From: David Weintraub [mailto:qazwart@gmail.com] 
Sent: Tuesday, June 12, 2007 3:26 AM
To: Ant Users List
Subject: Mail failing in build.xml file

I have a very straight forward build.xml file:

<project name="test" default="test" basedir=".">
    <target name="test">
        <mail
            from="dweintraub@solbright.com"
            subject="Test Email"
            mailhost="192.168.128.100"
            user="dweintraub"
            password="xxxxxxxx"
            message="This is a test email"
            failonerror="true">
            <to name="David Weintraub"
                address="dweintraub@solbright.com"/>
        </mail>
    </target>
</project>

When I attempt to execute it, I get the following error message:

test:
     [mail] Failed to initialise MIME mail: javax/mail/MessagingException

BUILD SUCCESSFUL


Which is strange because I set "failonerror" to "true".

Any ideas? I am currently sending mail via CruiseControl and that
works (and where I got the parameters from) so I know that it is
possible to send email from this machine.

--
David Weintraub
qazwart@gmail.com

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message