ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jesuschrist Superstar" <ccris...@gmail.com>
Subject Re: -projecthelp option odd error
Date Thu, 10 May 2007 18:14:26 GMT
Thanks a lot.

I think the problem is that i am running Ant from Eclipse IDE and not in a
stand-alone distribution. I installed the same version you have and
everything works fine.

You're right about the simbols i used in my descriptions, thanks for the
advice.

Regards

On 5/9/07, Bill Rich <bill@wilandra.com> wrote:
>
> I don't have any problems with your file on my Windows XP system (and it
> surprises me).
> This is what I get when I run it:
> C:\TEMP>ant -p
> Buildfile: build.xml
> OMAP_19.12M4 Build script
> Main targets:
>
> All        --> Builds an integrated Symbian S60 image
> Baseport   --> Builds the Symbian S60 Baseport
> DSPBridge  --> Builds the 19.xDSP/BIOS Bridge
> Default target: All
> C:\TEMP>
>
> I am running Ant 1.6.5.
>
> The reason it surprises me is that you use the greater-than symbol (>)
> in your description attributes. This should be a restricted character
> and should behave by closing the target element but it does not. I
> believe the greater-than symbol should be specified as the element name
> and not the symbol. Another thing is that the construct "-->" is a close
> comment so it would be better if you did not use it even if it works.
> Using that can cause some readability issues for anyone familiar with XML.
>
> At any rate, I haven't a clue as to exactly what your problem is but
> IMHO I would remove the "-->" from the descriptions to see what happens.
> HTH Bill
>
> Jesuschrist Superstar wrote:
> > Hello
> >
> > I'm working in my very first ant file and i noticed an error while
> > executing
> > ant with the -projecthelp option. This is my xml file:
> >
> > <?xml version="1.0" encoding="UTF-8"?>
> >
> > <project name="OMAP_19.12M4 Build" default="All" basedir=".">
> >    <description>OMAP_19.12M4 Build script</description>
> >
> >    <!-- =================================
> >          target: All
> >         ================================= -->
> >    <target name="All" depends="Baseport,DSPBridge" description="-->
> > Builds
> > an integrated Symbian S60 image">
> >        <echo>Symbian S60 complete environment image successfully
> > created</echo>
> >    </target>
> >
> >    <!-- =================================
> >          target: Baseport
> >         ================================= -->
> >    <target name="Baseport" description="--> Builds the Symbian S60
> > Baseport">
> >        <echo>Symbian S60 Baseport built successfully</echo>
> >    </target>
> >
> >    <!-- =================================
> >          target: DSPBridge
> >         ================================= -->
> >    <target name="DSPBridge" depends="" description="--> Builds the
> > 19.xDSP/BIOS Bridge">
> >        <echo>19.x DSP/BIOS Bridge built successfully</echo>
> >    </target>
> > </project>
> >
> > And this is the output of ant -p command:
> >
> > Buildfile: C:\Documents and Settings\x0075480\My Documents\My TI
> > Documents\s60\SYMBIAN-S60_RLS_19.12M4\ant_project\test.xml
> > OMAP_19.12M4 Build script
> > Default target:
> >
> > All        --> Builds an integrated Symbian S60 image
> > Main targets:
> >
> > All        --> Builds an integrated Symbian S60 image
> > Baseport   --> Builds the 19.x DSP/BIOS Bridge
> > DSPBridge  --> Builds the Symbian S60 Baseport
> > Subtargets:
> >
> > When i change the description parameter int the "DSPBridge" target to
> > "-->B", for example, it shows the help correctly:
> >
> > Default target:
> >
> > All        --> Builds an integrated Symbian S60 image
> > Main targets:
> >
> > All        --> Builds an integrated Symbian S60 image
> > Baseport   --> Builds the Symbian S60 Baseport
> > DSPBridge  -->B
> > Subtargets:
> >
> > However, i'm getting different results when changing the values of the
> > description.  any idea of what's happenning?
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message