ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Tiley" <sti...@meraksystems.com>
Subject Process Fork Failed
Date Wed, 16 May 2007 01:35:36 GMT
Hi there,

I have successfully been using ant(1.6.5) to run a number of test suites
for months. I use the JAVA_HOME is set to the IBM JDK and ANT_HOME is
set,

 

All of a sudden I try and I see the following error and I have no idea
what has happened

 

C:\build\build.xml:562: Process fork failed.

 

The target I am trying to run looks like (it has not changed since I
created it).

 

<!-- This target runs the EJB JUNIT tests -->

<target name="test-ejb" description="Run the Junit test cases">

<echo>Running the EJB test suite</echo>

            <!-- run the tests -->

            <mkdir dir="logs"/>

            <junit printsummary="withOutAndErr" fork="true"
haltonfailure="false" failureproperty="ejb.tests.failed"
showoutput="true">

                        <classpath>

                                    <path refid="test-path" />

                        </classpath>

                        <jvmarg value="-Xmx256M" />

                        <formatter type="xml" />

                        <test name="${ejb.test.class}"
outfile="${log.dir}/${ejb-test-results.file}" />

            </junit>

</target>

 

When I turn on the verbose flag in ant, I see the following

 

 

BUILD FAILED

C:\sean\afsc_source_head\build\build.xml:587: Process fork failed.

        at
org.apache.tools.ant.taskdefs.optional.junit.JUnitTask.executeAsForked(J
UnitTask.java:882)

        at
org.apache.tools.ant.taskdefs.optional.junit.JUnitTask.execute(JUnitTask
.java:685)

        at
org.apache.tools.ant.taskdefs.optional.junit.JUnitTask.executeOrQueue(JU
nitTask.java:1434)

        at
org.apache.tools.ant.taskdefs.optional.junit.JUnitTask.execute(JUnitTask
.java:632)

        at
org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)

        at org.apache.tools.ant.Task.perform(Task.java:364)

        at org.apache.tools.ant.Target.execute(Target.java:341)

        at org.apache.tools.ant.Target.performTasks(Target.java:369)

        at
org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)

        at org.apache.tools.ant.Project.executeTarget(Project.java:1185)

        at
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecut
or.java:40)

        at
org.apache.tools.ant.Project.executeTargets(Project.java:1068)

        at org.apache.tools.ant.Main.runBuild(Main.java:668)

        at org.apache.tools.ant.Main.startAnt(Main.java:187)

        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)

        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)

Caused by: java.io.IOException: CreateProcess: "C:\Program
Files\IBM\WebSphere\AppServer\java\jre\bin\java.exe"........

 

 

Any ideas as to what may be happening would be greatly appreciated.

 

 

Thanks

Sean

 

 

 

 

 

 

 

 

 

 

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message