ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shafiulla, Mohammed" <mohammed.shafiu...@hp.com>
Subject RE: OpenVMS system - connection fails
Date Tue, 08 May 2007 05:32:19 GMT
When a telnet command is invoked from command line, it works.

Please find the portion of build,

<property name="ovmsalpha.build.machine" value="full_machinename"/>
<property name="ovmsalpha.build.user" value="barnes"/>
<property name="ovmsalpha.build.passwd" value="clientteambangalore"/>
<property name="ovmsalpha.build.dir" value="DISK$ENG0:[BARNES]"/>
<property name="ovmsalpha.telnet.timeout" value="600"/>
<property name="build.client.workspace" value="Shafi_test"/>
<property name="ovmsalpha.build.target" value="" />


<target name="build" description="build the ovmsalpha client"
depends="init,buildonly">
</target>

<target name="init" description="initialize the environment">
  <echo>Build machine: ${ovmsalpha.build.machine}</echo>
</target>


<!-- <target name="build" description="build the ovmsalpha client"
depends="init,bootstrap,buildonly,buildandcheckin"> -->


<target name="buildonly">

  <telnet server="${ovmsalpha.build.machine}"
timeout="${ovmsalpha.telnet.timeout}" userid="${ovmsalpha.build.user}"
password="${ovmsalpha.build.passwd}" >

    <read>$</read>
    <write>sh def</write>

    <echo>Build machine: ${ovmsalpha.build.machine}</echo>

    <read>$</read>
    <write>sh logi TRUECM_ACCOUNT</write>

    <read>$</read>
    <write>dir PACKAGECLIENT_JRE1426.COM</write>

    <read>$</read>
    <write>@PACKAGECLIENT_JRE1426.COM V3.95-34</write>

    <read>$</read>

  </telnet>


</target>


Shafi



-----Original Message-----
From: Anderson, Rob (Global Trade) [mailto:Rob.Anderson@nike.com] 
Sent: Monday, May 07, 2007 11:49 PM
To: Ant Users List
Subject: RE: OpenVMS system - connection fails

Please post the relevant portion of your build.xml. Also, can you
connect to the system with telnet on the command line? Is the system
configured to allow telnet connections?

I would recommend using the sshexec rather than telnet.

-Rob Anderson

> -----Original Message-----
> From: Shafiulla, Mohammed [mailto:mohammed.shafiulla@hp.com] 
> Sent: Thursday, May 03, 2007 2:58 AM
> To: user@ant.apache.org
> Subject: OpenVMS system - connection fails
> 
> Hi,
> 
> I tried connecting to OpenVMS system using telnet command (as 
> part of XML file), it fails whereas it connects to HPUX machine.
> 
> Let me know whether ANT supports connection to OpenVMS 
> Systems. If not, is there any alternate solution in ANT 
> software for connection.
> 
> Thanks!
> 
> Regards
> Shafi
>   
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message