ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From swapnil_r_84 <swapnil_r...@yahoo.co.in>
Subject build doesn't complete after tomcat starts
Date Wed, 23 May 2007 09:20:43 GMT

i am trying to start tomcat from ant. It does start but build never completes
after tomcat is started. After i shut down tomcat remaining build begins to
run(control comes back).

i want tomcat running & my ant targets to get executed completely till end:

<?xml version="1.0" encoding="ISO-8859-1"?>

<project name="insync-ibpc-1.0" basedir="." default="all">


<property name="tomcat.home" value="D:\\Tomcat 5.5" /> 

<target name="Selenium1">

<exec dir="${tomcat.home}/bin"
executable="${tomcat.home}/bin/shutdown.bat"/> 

<!-- start the tomcat-->
 <exec dir="${tomcat.home}/bin"
executable="${tomcat.home}/bin/startup.bat"/> 

</target>

<target name="Selenium11" depends="Selenium1">
<taskdef resource="selenium-ant.properties">
    <classpath>
        <pathelement location="selenium-server.jar"/>
    </classpath>
</taskdef>
<selenese 
    suite="tests/myTestSuite.html"
    browser="*firefox"
    results="results.html"
    multiWindow="true"
    timeoutInSeconds="900"
    startURL="http://localhost:8080" />
</target>


</project>


Please help.
-- 
View this message in context: http://www.nabble.com/build-doesn%27t-complete-after-tomcat-starts-tf3802838.html#a10760296
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message