ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bijan Vakili" <Bijan.Vak...@cryptologic.com>
Subject RE: p4sync question
Date Thu, 05 Apr 2007 14:29:41 GMT
Never mind regarding this issue.  I resolved the problem myself (some
property values, like the user name, had unwanted trailing spaces).

Thanks.

 
Bijan Vakili
Senior Software Developer
 
Cryptologic Inc. 
55 St-Clair W, 3rd floor, Toronto, Ontario, M4V 2Y7
Phone 416.545-1455 Ext 5892
E-Mail: bijan.vakili@cryptologic.com
SKYPE: bijanvakili 

This message, including any attachments, is confidential and/or
privileged and contains information intended only for the person(s)
named above. Any other distribution, copying or disclosure is strictly
prohibited. If you are not the intended recipient or have received this
message in error, please notify us immediately by reply email and
permanently delete the original transmission from all of your systems
and hard drives, including any attachments, without making a copy.
-----Original Message-----
From: Bijan Vakili [mailto:Bijan.Vakili@cryptologic.com] 
Sent: Wednesday, April 04, 2007 12:34 PM
To: user@ant.apache.org
Subject: p4sync question

Hi,

 

I'm setting up a build system on a server.  I've created a dedicated
Perforce user account to perform builds and placed it in a group that
will allow it to be permanently logged in with no timeout.  I need my
Ant scripts to rely on the Perforce ticket to perform any Perforce
related tasks.

 

I'm using the <p4sync> task as follows:

 

<p4sync 

    port="myserver:1666" 

    user="myuser" 

    client="myclient" 

    view="//depot/my/path/..." 

    force="true" 

/>

 

I have also set the following Perforce variables using "p4 set" both for
the user and for the system using '-s':

 

P4CLIENT=myuser

P4PORT=myserver:1666

P4TICKETS=C:\Program Files\CruiseControl\p4tickets.txt

P4USER=agilebuild

 

All of these values have been verified (I've even debugged the Ant
script directly in Eclipse).

 

But I am continually getting the following error:

 

[p4sync] error: Perforce password (P4PASSWD) invalid or unset.

 

Can anyone help?

 

 

Thanks in advance,

 

 

Bijan Vakili

Senior Software Developer

 

Cryptologic Inc. 

55 St-Clair W, 3rd floor, Toronto, Ontario, M4V 2Y7
Phone 416.545-1455 Ext 5892
E-Mail: bijan.vakili@cryptologic.com
<mailto:bijan.vakili@cryptologic.com> 

SKYPE: bijanvakili 

This message, including any attachments, is confidential and/or
privileged and contains information intended only for the person(s)
named above. Any other distribution, copying or disclosure is strictly
prohibited. If you are not the intended recipient or have received this
message in error, please notify us immediately by reply email and
permanently delete the original transmission from all of your systems
and hard drives, including any attachments, without making a copy.

 


______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message