ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brown, Carlton" <Carlton.Br...@BellSouth.com>
Subject Escaping double quotes in properties?
Date Sun, 11 Mar 2007 23:48:56 GMT
I'm trying to store double quotes in a property, to print out a phrase
like:   
It's spelled "potatoe"

The manual provides only this cute bit of advice:  
Want unusual characters?  Escape them \u0456 or \" style.

Problem is, it doesn't seem to work, or I'm misunderstanding it:
<?xml version="1.0"?> 
<project name="test" default="build">
        <target name="build">
                <property name="foo" value="It's spelled \"potatoe\""/>
                <echo message="${foo}"/>
        </target>
</project>

Buildfile: test.xml

BUILD FAILED
/tmp/test.xml:4: Element type "property" must be followed by either
attribute specifications, ">" or "/>".

Total time: 0 seconds

I also tried \u201C and \u201D which I believe are the correct unicode
quotes, but Ant just printed them literally.

Help?




*****

The information transmitted is intended only for the person or entity to which it is addressed
and may contain confidential, proprietary, and/or privileged material. Any review, retransmission,
dissemination or other use of, or taking of any action in reliance upon this information by
persons or entities other than the intended recipient is prohibited. If you received this
in error, please contact the sender and delete the material from all computers. GA625



Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message