ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brown, Carlton" <Carlton.Br...@BellSouth.com>
Subject RE: Junit test fails in ant but not in Eclipse
Date Wed, 07 Mar 2007 14:35:34 GMT
These things almost always come down to classpath but it's hard to tell
without more info.   In particular I found that Java 1.3 and 1.4 are
missing a lot of libs needed to run junit, but Java 1.5 already comes
with everything.

When you say you ran it in Eclipse, did you simply select "run as junit"
or did you launch the Ant script from Eclipse?
When you say you ran it in Ant, did you launch the Ant script from
Eclipse, or did you run it by hand on the command line?
Are you launching Eclipse with the same VM that you see when you type
"java -version" at your command line?

-----Original Message-----
From: Mikael Petterson (KI/EAB) [mailto:mikael.petterson@ericsson.com] 
Sent: Wednesday, March 07, 2007 5:57 AM
To: user@ant.apache.org
Subject: Junit test fails in ant but not in Eclipse

Hi,

I run a junit test ( junit 3.8.1 in both) in Eclipse it works just fine.
Then I run the test in Ant using:

<target  name="test:test" depends="test:postcompile" description="run
all tests">
  <junit showoutput="yes" printsummary="on"  haltonfailure="no"
fork="on" failureproperty="junit_test_failed" forkmode="perBatch">
    <jvmarg value="-Xmx756M" />
    <jvmarg
value="-Demma.coverage.out.file=${coverage.dir}/coverage.emma" /> 
    <jvmarg value="-Demma.coverage.out.merge=true" /> 
    <classpath>
     <pathelement location="${out.instr.dir}"/>
     <pathelement location="${test.classes.dir}"/>
     <pathelement location="${classes.dir}"/>
     <path refid="test.classpath"/>
     <path refid="emma.lib" />
   </classpath>
   <!--<formatter type="brief" usefile="true"/>-->
   <formatter type="xml" usefile="true"/>
    <batchtest todir="${coverage.dir}">
     <fileset dir="${test.classes.dir}">
      <!--<include name="**/TestItAllCreate*"/>-->
      <!--<include name="**/TestRecover*"/>-->
      <include name="**/TestItAll.class"/>
      <exclude name="**/alarm/tb/sut/*Test.class"/>
      <include name="**/sut/*Test.class"/>
      <exclude name="**/mock/**"/>
     </fileset>
    </batchtest>
   </junit>
   </target>

The test fails with an NullPointerException.

How are junit tests executed in ant?

Anyone knows if the jvm is restarted per suite or something. Since there
must be differences in what objects are still in the environment.
All ideas and hints are greatly appreciated!

Cheers,

//mikael

*****

The information transmitted is intended only for the person or entity to which it is addressed
and may contain confidential, proprietary, and/or privileged material. Any review, retransmission,
dissemination or other use of, or taking of any action in reliance upon this information by
persons or entities other than the intended recipient is prohibited. If you received this
in error, please contact the sender and delete the material from all computers. GA624



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message