ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William Walsh" <WWa...@curamsoftware.com>
Subject file.encoding within <junit> task
Date Wed, 07 Mar 2007 11:01:49 GMT
Is anyone else using Ant's <junit> task on z/OS and having various
file/string encoding issues?  We're using Ant 1.6.2 on z/OS 1.7 with WAS
6.1's Java 5 and some of our tests get errors due to XML parsing errors.
In looking into this issue it appears that the file.encoding property
set to "UTF-8" at <junit> invocation gets changed by Ant somewhere along
the way back to the default IBM-1047 encoding when some of the tests
run.

The way I've gotten around this is to implement a simple RMI class to
invoke junit so that encoding is still honored from the <java> task to
the test class, but we then don't get the Ant-builtin HTTP Junit report
processing.

Thanks in advance,
William


The information in this email is confidential and may be legally privileged.
It is intended solely for the addressee. Access to this email by anyone else
is unauthorized. If you are not the intended recipient, any disclosure,
copying, distribution or any action taken or omitted to be taken in reliance
on it, is prohibited and may be unlawful. If you are not the intended
addressee please contact the sender and dispose of this e-mail. Thank you.

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message