ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Hatton" <>
Subject RE: [SEC=UNCLASSIFIED] Ant filterset doesnot work
Date Thu, 01 Mar 2007 18:01:47 GMT
A favourite that trips me up is that the destination files are newer
than the source files, so no copy actually happens. Maybe you need to
add overwrite="true" to the <copy>?

Hope this helps,

-----Original Message-----
From: jake_ryan [] 
Sent: 01 March 2007 16:14
Subject: Re: [SEC=UNCLASSIFIED] Ant filterset doesnot work

Forgot to mention.. Here are the files:


After running ant, still I see DbUser and DbPassword as shared/shared. I
expected they wouldbe itsme/itsme.

I tried to use begintoken="%" endtoken="*" aswell, but of no use.

jake_ryan wrote:
> I have a property file-1 where cc.db.username and cc.db.password are 
> defined.
> There is property file-2 with tokens DbUser and DbPassword with some 
> default values, that will be copied to a directory.
> My task is to replace values of DbUser and DbPassword in file-2 with 
> values of cc.db.username and cc.db.password in file-1.
> I have a code like this:
>        <echo message="Copying SPP_CC config file to 
> ${jboss.local.conf.dir}"></echo>
>        <copy file="${cc.config.files.dir}/"
> tofile="${jboss.local.conf.dir}/"
>            <filterset>
>                <filter token="DbUser" value="${cc.db.username}"/>
>                <filter token="DbPassword" value="${cc.db.password}"/>
>            </filterset>
>        </copy>
> After running ant, I get successful message but still the copied file 
> contain old values. How to debug this? What is wrong with my code?
> Thanks a bunch!

View this message in context:
Sent from the Ant - Users mailing list archive at

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message