ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles Scokart" <gscok...@gmail.com>
Subject Using XSLT2
Date Mon, 19 Mar 2007 08:30:48 GMT


I try to use the function 'lower-case' in an xslt transformation.  This
function requires an XSLT2 engine, so I tried to use saxon as described in
http://wiki.apache.org/ant/UsingAntWithXSLT20AndSaxon.

I tried all approach 
 - Place saxon8.jar in the classpath attribute of the XSLT tarsk
 - Place saxon8.jar as a child classpath element of the XSLT task
 - Place it on the command line with the -lib option
 - Place the jar in ANT_HOME/lib

But it always failed.  Xalan is never found.

When I run my script in debug mode I see :

Class org.apache.tools.ant.taskdefs.optional.TraXLiaison loaded from parent
loader (parentFirst)
     [xslt] Using class org.apache.tools.ant.taskdefs.optional.TraXLiaison
     [xslt] In file d:\dev\workspace_1.5\RAD7FullEAR\test.xml time:
1174054857031
     [xslt] Out file d:\dev\workspace_1.5\RAD7FullEAR\target\ivy.xml time: 0
     [xslt] Style file ivy_template.xsl time: 1174061142023
     [xslt] Processing d:\dev\workspace_1.5\RAD7FullEAR\test.xml to
d:\dev\workspace_1.5\RAD7FullEAR\tar
get\ivy.xml
     [xslt] Loading stylesheet
d:\dev\workspace_1.5\RAD7FullEAR\ivy_template.xsl
Couldn't load ResourceStream for
META-INF/services/javax.xml.transform.TransformerFactory
Class org.apache.xalan.processor.TransformerFactoryImpl loaded from parent
loader (parentFirst)

It seems that TraXLiaison is loaded from a parent loader that don't have the
saxon8.jar in his path
(META-INF/services/javax.xml.transform.TransformerFactory should be loaded
from this jar).


I use ant 1.7 with an IBM jvm 1.5. in cygwin.  You can find the ant
-diagnostic in attachment.


Can anyone help me?

Thanks,

Gilles Scokart



Mime
View raw message