ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Close" <acl...@gmail.com>
Subject Re: Issues with ANT 1.7 and Linux???
Date Fri, 16 Feb 2007 14:38:41 GMT
Steve, thanks for the reply.


On 2/16/07, Steve Loughran <stevel@apache.org> wrote:
> Andrew Close wrote:
>
> > so when i run ANT in debug mode i see the following:
> >
> > [property] Loading /home/scm/CC_BUILD/projects/RSA/build.properties
> > [property] Unable to find property file:
> > /home/scm/CC_BUILD/projects/RSA/build.properties
> >
> > obviously ANT was able to translate the ${dev.root} property correctly
> > because the fully qualified path shows up in the output.  but for some
> > reason it is unable to find the file...
> >
>
> 1. you can use <loadproperties> which will fail early if the file is
> missing; may be useful.

i'll give that a try, but i'm positive the file is there. :)

> 2. this isnt a clearcase filesystem is it?

no, the filesystem on the Linux box is ext3.

>
> 3. there is something odd going on here, and it has to be the path is
> not right, case wrong, or permissions. Linux is used a lot by the ant
> developers, and we'd notice if <property file> failed.

i totally agree. :)  i've tried to verify each of the three things
you've mentioned multiple times.
i don't know a better way to verify the path.  i've cut & paste the
path into another terminal and am able to open the file in vi.
case shouldn't be an issue since the cut & paste technique should have
sorted that out.
i've changed my entire working directory structure and contents to 777
so it shouldn't be a permissions issue.
i'm really at a loss.  i agree it's weird.  i've used ANT on WinXP,
Mac OS, and Linux; but haven't used it on Linux in a year or two...

any other suggestions?  any other info i can provide that may help
diagnose the problem?
thanks again.

andy

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message