ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Levy-Lambert <anto...@gmx.de>
Subject Re: Issues with ANT 1.7 and Linux???
Date Fri, 16 Feb 2007 03:08:03 GMT
 From your log file, may be your property file should be loaded from

> /home/scm/CC_Build/projects/RSA/build.properties

not from

> /home/scm/CC_BUILD/projects/RSA/build.properties

Best regards,

Antoine

On Feb 15, 2007, at 4:04 PM, Andrew Close wrote:

> hi all,
>
> i did a bit of Googling and searched the archive but couldn't find
> quite the same situation mentioned that i'm in, so i figured i'd ask
> here. :)
>
> we do our development on WinXP SP2 using jdk 1.4.2_06.  i've written
> new build scripts for our project using ANT 1.7.  everything works
> fine in our development environment; however, when i attempted to set
> up ANT & CruiseControl on a linux build machine the build is no longer
> working.
> i'm getting FileNotFound exceptions even though the files exist and
> are world readable.
>
> the error i'm getting is during the build is:
>
> [scm@nap2lsscm1 providerinterfaces]$ ant -verbose -debug >  
> ant_output.txt
>
> BUILD FAILED
> /home/scm/CC_Build/projects/RSA/components/ProviderCommonServices/ 
> providerinterfaces/build.xml:48:
> The following error occurred while executing this line:
> java.io.FileNotFoundException:
> /home/scm/CC_Build/projects/RSA/components/ProviderCommonServices/ 
> providerinterfaces/${cn
> s.script.root}/component_build.xml (No such file or directory)
>
> looking at the path above you can see that ${cns.script.root} is not
> being translated.  this property is defined in the build.properties
> file.  the build.properties file doesn't look like it's being loaded
> according to the debug output:
>
> [property] Loading /home/scm/CC_BUILD/projects/RSA/build.properties
> [property] Unable to find property file:
> /home/scm/CC_BUILD/projects/RSA/build.properties
>
> for some reason that property file isn't being found, even though that
> is the correct path to the file and the file is world readable.
>
> i've attached an ant_diagnostics.txt file that contains the output of
> ant -diagnostics.
> i've also attached ant_output.txt which contains the -verbose -debug
> output from the build i ran above.
> hopefully somebody else has already come across this problem and can
> clue me in. :)
>
> thanks for any help.
>
> andy
>
> linux box info:
>
> Red Hat Enterprise Linux AS release 4 (Nahant Update 3)
>
> Linux version 2.6.9-34.ELsmp (bhcompile@hs20-bc1-7.build.redhat.com)
> (gcc version 3.4.5 20051201 (Red Hat 3.4.5-2)) #1 SMP Fri Feb 24
> 16:54:53 EST 2006
> <ant_diagnostics.txt>
> <ant_output.txt>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message