ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guy Rouillier <guyr-...@burntmail.com>
Subject Java 1.5.0_10 won't allow SAR in classpath
Date Sun, 25 Feb 2007 17:01:34 GMT
One of our build.xml files includes a SAR (JBoss server archive) in the
classpath, along with a bunch of other JARs.  Up until Java JDK 1.5.0_04
at least, this was working fine.  I recently upgraded my workstation to
1.5.0_10, and now this no longer works.  I added verbose="on" to my
javac task, and very clearly, when using JDK 1.5.0_04, the line "search
path for class files" includes the SAR; when using JDK 1.5.0_10, the SAR
is not included.  All the other JARs are present; it just ignores the
SAR.  This is repeatable.

I tried upgrading to Ant 1.7.0 and to the newest available JDK 1.5.0_11,
and still I'm getting the same result.  I'm perplexed how the JDK
version can affect the classpath that Ant defines.  Unless Ant is using
some JDK helper class to build up the classpath one JAR at a time, and
that helper class is rejecting the SAR?  What options do I have?  Thanks.

-- 
Guy Rouillier

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message