ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Rue <jon...@u.washington.edu>
Subject Question about debug output
Date Fri, 09 Feb 2007 17:55:43 GMT
I'm having issues building with ant 1.6.5 integrated into the netbeans 
5.5 ide. This is a project built outside the ide and has a very good 
build script that works just find from the command line. When i run the 
same script in the ide however it errors out with a lovely 
java.lang.NoClassDefFoundError. I've output debug info for both runs and 
it looks pretty similar to me. There does appear to be class loader 
differences (at least things are loading in a different order).

The question I have is that what does it mean when I see a line like:
    Finding class org.apache.jasper.compiler.JDTCompiler

that doesn't have an accompanying loaded from statement?
    Loaded from C:\Program 
Files\netbeans-5.5\enterprise3\apache-tomcat-5.5.17\common\lib\jasper-compiler.jar 


In the successful build I am seeing these two lines together with no 
corresponding loaded from:
    Finding class org.eclipse.jdt.internal.compiler.env.INameEnvironment
    Finding class org.eclipse.jdt.internal.compiler.env.INameEnvironment

In the unsuccessful build I see:
    Finding class org.eclipse.jdt.internal.compiler.env.INameEnvironment
    Error in class org.apache.jasper.JspC
    Exiting C:\Programming\cpas\trunk\server\build.xml.

Any ideas?

-- 
Jon Rue
Bioinformatics Systems Programmer
Katze Lab, University of Washington
960 Republican St, Seattle WA 98109
(206) 732-6038


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message