ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anderson, Rob (Global Trade)" <Rob.Ander...@nike.com>
Subject RE: Ant sshexec random failuresrun a fai
Date Thu, 08 Feb 2007 18:08:41 GMT
> -----Original Message-----
> From: cprice [mailto:cprice@its.to] 
> Sent: Wednesday, February 07, 2007 2:37 PM
> To: user@ant.apache.org
> Subject: Ant sshexec random failuresrun a fai
> 
> 
> Hi there;
> 
> I run a deploy system using ant with sshexec and scp. My 
> deploy consists of
> sshexec calls to shut down running applications on remote 
> servers, copy of
> files via scp to remote servers, and then subsequent sshexec 
> calls to start
> up applications on remote servers. 
> 
> My problem is that my ant sshexec calls fail randomly with 
> "Remote command
> failed with exit status -1". I'll have 20 successful deploys 
> in a row, a
> failure, 3 more successes, 2 failures, etc... Effectively 
> what seems to be
> happening is that the failing sshexec tasks do not attempt to make a
> connection to the remote system. I've esteablished this by 
> watching strace
> and lsof output of the running ant process and noting the 
> abscence of a tcp
> socket connection to the remote system. Also, the instant I 
> get the remote
> command failed error I can connect via ssh by hand (CLI) to the remote
> system with no issues. I have also run scripts that 
> continually run remote
> commands against all remote systems while running the ant deploy.
> 
> My deploy system is rhel4, OpenSSH_3.9p1, OpenSSL 0.9.7a Feb 19 2003.
> 
> Target systems are a mixture of rhel3, OpenSSH_3.6.1p2, SSH protocols
> 1.5/2.0, OpenSSL 0x0090701f
> and windows 2003 server running cygwin, OpenSSH_4.3p2, 
> OpenSSL 0.9.8b 04 May
> 2006 
> 
> I was originally seeing this behaviour under ant-1.6.5, so I 
> upgraded to
> ant-1.7.0 with no changes. I also upgraded my ant-1.7.0 to 
> jsch-0.1.31.jar
> based on some anecdotal evidence I saw in the jsch changelog.
> 
> My ant install was running under jdk 1.4.2_11, which we 
> upgraded to jdk
> 1.6.0  with no change.
> 
> ANY help you can provide will be greatly appreciated.
> 
> Cheers,
> Chris
> 
> 
> 
> -- 
> View this message in context: 
> http://www.nabble.com/Ant-sshexec-random-failuresrun-a-fai-tf3
> 190085.html#a8855696
> Sent from the Ant - Users mailing list archive at Nabble.com.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> 
> 


Chris, Some more info would be helpful. Please post the relavant portion
of your build.xml and the verbose output from Ant. Be sure to remove any
sensitive data. You say there are two target systems... Does it only
fail when attempting to sshexec to a particular one?

-Rob Anderson


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message