ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jack J. Woehr" <>
Subject Ant 1.7.1 Alpha problems with BSF
Date Wed, 03 Jan 2007 19:41:20 GMT
A month ago with 1.7.0RC1 my BSF problems ended when Jacob Kjome wrote:

 > On Dec 6, 2006, at 5:33 PM, Peter Reilly wrote:
 > > You can use bsf 2.4.0 and rhino 1.5r4 but
 > I definitely have Rhino 1.6.5. I *theenk* I have the 2.4.0 of
 > BSF but I'll download again to be sure ... that is, I shall when
 > the BSF download page uncrashes.
 > > you need apache-commons as well (for bsf 2.4)
 > Excuse my ignorance. Everything on the Apache Commons pages? Or
 > one particular component? Commons seems to be many small projects.

 >He meant Apache Commons Logging

Now I've built 1.7.1 from fresh checkout and with the same lib jars  
used in lib/optional,
when I try to build my project I now get:

/usr/local/work/SoftWoehr/com/SoftWoehr/build.xml:114: The following  
error occurred while executing this line:
/usr/local/work/SoftWoehr/com/SoftWoehr/macros.xml:61: The following  
error occurred while executing this line:
/usr/local/work/SoftWoehr/com/SoftWoehr/macros.xml:39: Unable to load  
a script engine manager (org.apache.bsf.BSFManager or  

Total time: 0 seconds
$ ant -version
Apache Ant version 1.7.1alpha compiled on January 3 2007

What lib versions must I change to, please, in the optional portion  
of Ant build?

Jack J. Woehr
Director of Development
Absolute Performance, Inc.
303-443-7000 ext. 527

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message