ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nb123 <nbos...@gmail.com>
Subject RE: problem sending attachments
Date Wed, 10 Jan 2007 10:22:43 GMT

yes that is all in place, the jar files.
as i said the textual mails are going through but the attachments are not




David Corley (AT/LMI) wrote:
> 
> You need to add the java activation framework and java mail jars to your
> classpath.
> They don't come with Ant or Java and can be download here:
> http://java.sun.com/products/javamail/
> 
> And here
> http://java.sun.com/products/javabeans/jaf/downloads/index.html
> 
> Download the 2 jars, add them to your ant classpath....and it should
> work fine.
> 
> By the way, the Ant documentation tells you about this on the manual
> page for the mail task. 
> 
> 
> This communication is confidential and intended solely for the
> addressee(s). Any unauthorized review, use, disclosure or distribution
> is
> prohibited. If you believe this message has been sent to you in error,
> please notify the sender by replying to this transmission and delete
> the message without disclosing it. Thank you.
> E-mail including attachments is susceptible to data corruption,
> interception, unauthorized amendment, tampering and viruses, and we only
> send and receive e-mails on the basis that we are not liable for any
> such corruption, interception, amendment, tampering or viruses or any
> consequences thereof.
> 
> 
> -----Original Message-----
> From: nb123 [mailto:nbose83@gmail.com] 
> Sent: 10 January 2007 11:05
> To: user@ant.apache.org
> Subject: problem sending attachments
> 
> 
> i've tried sending attachments with the mail. the normal text mails are
> going through. but attachments are not. 
> 
> i am getting an error::
> The <mail> type doesn't support the nested "attachments" element.
> 
>  please help me out.
> 
> my build.xml file:
> 
> <?xml version="1.0"?>
> 
> 
> <project name="Ant mail Task" default="mail" basedir=".">
> 
> <target name="mail">
>      <mail mailhost="203.169.230.211" subject="test">
> 		  <from address="admin@zimbra.vsnl.in" />
> 		  <replyto address="admin@zimbra.vsnl.in" />
> 		  <to address="admin@zimbra.vsnl.in" />
> 		  <message>TEST MAIL FROM ANT</message>  
> 			
> 		<attachments>
> 		        <fileset dir="dist">
> 			<include name="**/*.jpg"/>
> 		         </fileset>
>                                  </attachments>
> 
>      </mail>
> </target>
> </project>
> --
> View this message in context:
> http://www.nabble.com/problem-sending-attachments-tf2951607.html#a825487
> 0
> Sent from the Ant - Users mailing list archive at Nabble.com.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/RE%3A-problem-sending-attachments-tf2951647.html#a8255126
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message