ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scot P. Floess" <flo...@mindspring.com>
Subject Trouble executing a beanshell script
Date Mon, 08 Jan 2007 17:36:56 GMT
All:

I was trying to execute a simple beanshell script from within my ant 
script (I tried using an example found in the documentation):

    <script language="beanshell">
        <classpath>
            <fileset 
dir="/home/sfloess/development/jplate/environment/lib" includes="*.
jar" />
        </classpath>
        System.out.println("Hello world");
    </script>

If I run Ant with "-lib 
/home/sfloess/development/jplate/environment/lib" command line option, I 
see the System.out.println() executed as I would expect.

However, if I do not use the -lib option, I get:  
"java.lang.NoClassDefFoundError:  org/apache/bsf/BSFException" error.  I 
assumed the classpath element would take care of this...but to no avail.

My lib dir contains bsf.jar and bsh-2.0b4.jar

Again, if I use the -lib command line param everything works fine.

Thanks ahead of time...

Scot

-- 
Scot P. Floess
27 Lake Royale
Louisburg, NC  27549

252-478-8087 (Home)
919-754-4592 (Work)

Chief Architect JPlate  http://sourceforge.net/projects/jplate
Chief Architect JavaPIM http://sourceforge.net/projects/javapim


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message