ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From joe P <joe.j...@yahoo.com>
Subject Re: How to set source from 1.4 to 1.5
Date Tue, 16 Jan 2007 10:02:13 GMT
Hi Wolverine,
It didn't do any harm to my build/workspace. It is
working fine. But I have changed all the sources of
all the build files of all my modules from 1.4 to 1.5.
If any of other module of your project is using old
version then application will not launch. You should
take care. It will throw this error 
"Unsupported major.minor version 49.0"


-Joe



--- wolverine my <wolverine.my@gmail.com> wrote:

> Hi!
> 
> Does it harm if we set <javac source="1.5" and
> target="1.5">?
> 
> The Ant manual highly recommend to always specify
> soruce and target attributes.
> 
> 
> On 1/15/07, Jan.Materne@rzf.fin-nrw.de
> <Jan.Materne@rzf.fin-nrw.de> wrote:
> > First of all you have to install a Java5
> Development Kit.
> > Having that installed as first on the PATH, Ant
> should do the rest automatically - if not specified
> something else.
> >
> > These two attributes are responsible for using
> former versions
> >  <javac source="" target="">
> > Dont use them or set them to "1.5".
> >
> >
> > Jan
> >
> >
> > >-----Urspr√ľngliche Nachricht-----
> > >Von: joe P [mailto:joe.java@yahoo.com]
> > >Gesendet: Montag, 15. Januar 2007 12:06
> > >An: user@ant.apache.org
> > >Betreff: How to set source from 1.4 to 1.5
> > >
> > >Hi ,
> > >Can any one suggest me solution to set source
> from 1.4 to 1.5 .
> > >I'm trying to run ant script but it is failing
> with the below message.
> > >
> > >generics are not supported in -source 1.4
> > >    [javac] (try -source 1.5 to enable generics)
> > >
> > >Please let me know how can i fix this?
> > >
> > >Thanks,
> > >Joe
> > >
> > >
> > >
> >
>
>_______________________________________________________________
> > >_____________________
> > >Don't pick lemons.
> > >See all the new 2007 cars at Yahoo! Autos.
> > >http://autos.yahoo.com/new_cars.html
> > >
> >
>
>---------------------------------------------------------------------
> > >To unsubscribe, e-mail:
> user-unsubscribe@ant.apache.org For
> > >additional commands, e-mail:
> user-help@ant.apache.org
> > >
> > >
> >
> >
>
---------------------------------------------------------------------
> > To unsubscribe, e-mail:
> user-unsubscribe@ant.apache.org
> > For additional commands, e-mail:
> user-help@ant.apache.org
> >
> >
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> user-unsubscribe@ant.apache.org
> For additional commands, e-mail:
> user-help@ant.apache.org
> 
> 



 
____________________________________________________________________________________
No need to miss a message. Get email on-the-go 
with Yahoo! Mail for Mobile. Get started.
http://mobile.yahoo.com/mail 

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message