ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re: <xmlproperty> intra-element attribute property resolution issue
Date Wed, 17 Jan 2007 15:48:23 GMT
Quoting Steve Loughran <stevel@apache.org>:

> Jacob Kjome wrote:
> > Quoting Steve Loughran <stevel@apache.org>:
>
> >
> > No, I get the same behavior in Ant-1.6.5.  I think this is a longstanding
> issue.
>
> uh oh. those are bad. Theres more of a risk that someone has been
> depending on it.
>

Except, in this case, I would think that it would have made people avoid trying
to use it because it wouldn't have worked for them, unless they wanted a the
resulting property value to be the literal referencing property declaration.  I
find that unlikely.  More likely, users seldom refer to an attribute from
another attribute in the same element and, if they attempt it, they find that
it doesn't work and probably use the nested element workaround.

> >
> >> have a look at the source and see if you can find a problem.
> >>
> >
> > I thought you might say that.  I was hoping more for a "yeah, the Ant team
> will
> > get it fixed for Ant-1.7.1", but so goes Open Source.  We'll see if I get
> time.
> >  In the meantime, I hope someone on the Ant team already familiar with the
> > XMLProperty task can look at this.
>
> file it as a defect, one with an Antunit test case that we can drop into
> the codebase. That way we can add the bug to the tree and the tests
> failing will remind us to fix.
>

Antunit, eh?  I'll have to read up on that first.  I'll try to create the issue
sometime tonight.


Jake

>
>
> -steve
>




---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message