ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Marsh" <jonat...@wso2.com>
Subject RE: document() function on missing file
Date Wed, 10 Jan 2007 01:41:26 GMT
Thank you, indeed ant -diagnostics didn't show up anything looking like
xalan.  I found I did have xalan in the 1.7.0alpha ant/lib directory, and
moving that version (2.5.1) into the 1.7.0 ant/lib directory indeed solved
the problem.  (I had other problems with xalan 2.7.0, so stuck with the old
one.)  Thanks for the handholding!

Jonathan Marsh - http://www.wso2.com - http://auburnmarshes.spaces.live.com
 
> -----Original Message-----
> From: Steve Loughran [mailto:stevel@apache.org]
> Sent: Tuesday, January 09, 2007 2:32 AM
> To: Ant Users List
> Subject: Re: document() function on missing file
> 
> Jonathan Marsh wrote:
> >> I dont think anything has deliberately been changed. If there is a
> >> difference between the 1.6.5 behaviour and the 1.7.0 behaviour, it
> >> probably consitutes a regression.
> >>
> >> You may be seeing differences between XSLT engines. Make sure you are
> >> using xalan and not java1.5 xsltc
> >>
> >> -steve
> >
> > How can I check that I'm using xalan?
> 
> do an ant -diagnostics and post the trace here. Not to me, to the
> mailing list.
> 
> > My ant file has nothing
> > processor-specific in it (no "processor", no "classpath"), so I assume
> I'm
> > using the default (Xalan).  I haven't done anything else esoteric like
> > installed other processors on my classpath (unless the oXygen plug in
> has
> > done it for me...)
> 
> If you are using Java5, and unless you have a copy of xalan.jar in your
> antlib, you get xltc. Ant does not redistribute xalan by default.
> 
> 
> > Seems like a regression to me, in that I used Ant 1.6.5 out of the box,
> and
> > more recently have been using a 1.7.0 alpha build with no problem.  If I
> > switch the Ant Home to the alpha build it still works, but when I point
> it
> > at the 1.7.0 final build it breaks.  Nothing else has been changed.
> 
> well, lets see that you are running xalan proper before we start
> worrying about regressions.
> 
> -steve
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message