ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chon, Ae H" <AE.H.C...@saic.com>
Subject Using 'exec' task with special characters in argument line.
Date Tue, 05 Dec 2006 19:57:59 GMT
Need help!

I'm having problems  getting trying to run a command in windows using
ant "exec" task:

In windows, I would would the following command:  cleartool find .
-version "created_since(yesterday)&&!(created_since(now))" -print

I tried to simulate this using 'exec' task...but it doesn't take special
characters like amperstand or double quotes.

How do i get around this?  I tried to used CDATA but i get the following
message (see code below):  Class
org.apache.tools.ant.types.Commandline$Argument doesn't support the
nested "line" element

Which i understand...but how do i get around this?

<exec executable="cmd" os="${os.name}" failonerror="false"
dir="${basedir}\..\..\..\..\Source" >
<arg>
<line><![CDATA[/c cleartool find . -version
"created_since(yesterday)&&!(created_since(now))" -print]]></line>
</arg>
</exec>

thanks in advance,

Ae Hwa Chon
Configuration Manager
 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message